WordPress カスタマイズ覚書

目次

WordPress 5.6

WordPress の jQuery が、5.6から最新になった。これにより、jQueryを使ったプラグインの挙動が変わっていた。

挙動が変わっていたプラグインは、 wp-jquery-lightbox (画像をポップアップ表示)

一時的な対策は、jQuery のバージョンを元に戻す(古いバージョン)。

  1. jQuery Manager for WordPress で、juery-2.2.4.min.js を使えば解消する。normal jQueryにも変更可能なため、debugが楽になる用途もある。
  2. enable-jQuery-migrate-helper で、ツール -> jQuery Migrate で、レガシー1.12.4 を使用する。wp-jquery-lightbox の公式フォーラムでの方法

PHPバージョンアップ

PHP Compatibility Checker (指定バージョンのPHPとの互換性チェック)

  • enable-jQuery-migrate-helper は、2.3までしか対応していない
  • プラグラムが大きいプラグインのチェックはスキップされてしまう。

Updating from PHP 7.2 to 7.4

Cloning Within One cPanel

Clam AntiVirus の定期実行

clamscanの定期実行

Command line interface

/usr/local/cpanel/3rdparty/bin/clamscan -i -r ~

ClamAV cron job

clamscanのオプション

https://clamav-jp.osdn.jp/jdoc/clamav.html#c4.1.1

その他