Flutter SDK のバージョンアップエラー (flutter upgrade error)

5月 22, 2020

Flutter SDK のバージョンアップでエラーが発生した時の顛末です。

結果的には、Flutter SDK を再インストールしました。


目次

経緯

flutter の cupertinoアプリサンプルを実行しようとしたところ、flutter sdk のバージョンが古いと言うエラーが発生

Running "flutter pub get" in flutter_cupertino_store_app...     
The current Flutter SDK version is 1.12.13+hotfix.9.

Because cupertino_store depends on provider >=4.1.0-dev+1 which requires Flutter SDK version >=1.15.17-pre.5, version solving failed.


pub get failed (1; Because cupertino_store depends on provider >=4.1.0-dev+1 which requires Flutter SDK version >=1.15.17-pre.5, version solving failed.)

git pull を実行。
※多分、本来は flutter upgrade を実行すべきだったと思います。

ローカルの修正が commit されていないと警告。
※自分では何も修正したつもりはありませんでしたが、cache などが更新されていた模様

git stash で変更を退避して、git pull してもエラーは解消せず。
※cache がクリアされた事が問題?

From https://github.com/flutter/flutter
 * branch                stable     -> FETCH_HEADerror: The following untracked working tree files would be overwritten by merge:	packages/flutter_tools/ide_templates/intellij/.idea/runConfigurations/manual_tests___density.xml.copy.tmpl
Please move or remove them before you merge.
Aborting

flutter upgrade を実施してみるとファイルがないエラー。

flutter/bin/cache/dart-sdk/bin/pub: No such file or directory
Error: Unable to 'pub upgrade' flutter tool. Retrying in five seconds... (7 tries left)

おそらく、flutter sdk のバグと自分の sdk upgrade の手順誤りが重なって問題が複雑になっていると思いますので、再セットアップすることに…。

flutter sdk の再インストール

初期インストールを参考に、再インストールしました。

ソースのチェックアウト

git clone https://github.com/flutter/flutter.git -b stable

flutter/bin へのパス設定

export PATH="$PATH:`pwd`/flutter/bin"

開発用バイナリをダウンロード

flutter precache

環境チェック

flutter doctor

一度設定は済んでいますので、警告はでませんでした。

警告が出た方は、こちらの記事を参考にして下さい

参考